You don’t stop riding because you’re getting old, but you get old when you stop riding.

Possible faulty neutral switch (CBF500)

Share
avatar
Arfa
Squiddy
Squiddy

Posts : 14
Location : London

Possible faulty neutral switch (CBF500)

Post by Arfa on Tue 19 Dec 2017, 1:21 pm

My has just dropped her CBF500 (in true comedy fashion whilst at standstill trying to dismount it in a car park...)
Bust clutch lever and bent gear lever. But also the neutral indicator is playing up now.

I get a bright green neutral light on dash when neutral is engaged. But when I stick it in gear I get a dimly lit neutral light on dash. Everything else seems fine, side stand switch cuts engine out etc. I'm guessing something is leaking a some voltage where it shouldn't be. Potentially the neutral switch? Wiring? Any tips on what to check where to better isolate issue?

However my wife did mention that on the day, she had bike trying to start itself when she wasn't pressing the starter button and then later not wanting to start. Not seen it reproduce this since - was a shit, wet day, dunno if water has got into electrics somewhere shorting something. Doused bike in WD40 in hope of clearing all water out, but does appear to be behaving now. But I'd like to get to bottom of things so she isn't left stranded somewhere in future.
avatar
wornsprokets
the 900
the 900

Posts : 1374
Location : dublin

Re: Possible faulty neutral switch (CBF500)

Post by wornsprokets on Tue 19 Dec 2017, 1:25 pm

Neutral switch is at front sproket at engine take off cover and u see it  disconnect the wire to it and take it off with a socket... new neutral switch about 16 pounds... your ment to change washer on switch i didnt

    Current date/time is Wed 26 Sep 2018, 5:22 am